need help Cranks normal but wont start - GL1800Riders
 3Likes
Reply
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 04-21-2017, 09:49 AM Thread Starter
Member
 
Join Date: Apr 2017
Posts: 5
need help Cranks normal but wont start

I was riding home and the bike just shot off, like the switch was turned off. As it was coasting to a stop I notice the FI light was blinking fast and slowed down as the bike was slowing down. Like I said now it just spins but no fire. FI light does not come on at all when the key is turned on or off, when I crank it for 10 or 15 seconds no codes. All fuses are good checked them multiple times. Swapped Fi relays swapped fuel pump relay with light and horn relay no change. checked for bad connection on ecm and relays. checked voltage on bank sensor looks normal. I cant seem to find anything on FI not working at all. Any help wil be appreciated.
joe4500 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-21-2017, 10:17 AM
Seasoned Member
 
Join Date: Dec 2010
Location: willow springs mo
Posts: 297
Check the kill switch.

2008 Titanium Gl1800
G709 @ 39 psi
Yokohama Avid Envigor ZPS RFT @ 28 to 30 psi
cjclint is offline  
post #3 of 13 (permalink) Old 04-21-2017, 10:36 AM
Seasoned Member
 
UNCLEJOHN's Avatar
 
Join Date: May 2009
Location: PALM BAY FLORIDA
Posts: 13,044
Wont crank if kill switch off. Someone will chime in on how to ck for codes think in neutral / kickstand down / hold throttle open all the way and crank for 10 seconds ??? Count the flashes short and long . Good luck. CHECK THE BATTERY N CONNECTIONS . BEEN KNOWN THAT BIKES WILL CRANK BUT NOT START WITH WEAK BATTERY.....BUT SEEING BIKE WAS RUNNING WOULD THINK ALTERNATOR WOULD KEEP IT GOING..??

WE ALL GOT TO GO SOMETIME .....ALWAYS TO SOON
FL. PROWLER # 62
DOUBLE DARKSIDER "WONKY" DRIVEGUARD REAR
BT 45 FRONT

Last edited by UNCLEJOHN; 04-21-2017 at 10:41 AM.
UNCLEJOHN is offline  
 
post #4 of 13 (permalink) Old 04-21-2017, 11:29 AM
Super Moderator
 
Ironhorse1800's Avatar
 
Join Date: Mar 2012
Location: Sugar Land, Texas
Posts: 4,147
Year and mileage?

Ironhorse1800, Hoss
2004 VTX1800N3 Red, Darkside Goodyear Assurance Tripletred 205/60/R16
2008 GL1800 ABS/NAV Red, Darkside #1273
[B]Michelin Primacy Alpin PA3 195/55/16 / [COLOR=#000000]Yokohama Avid Envigor ZPS
Ironhorse1800 is online now  
post #5 of 13 (permalink) Old 04-21-2017, 03:37 PM Thread Starter
Member
 
Join Date: Apr 2017
Posts: 5
Quote:
Originally Posted by Ironhorse1800 View Post
Year and mileage?
2001
24000
no codes no FI light at all
joe4500 is offline  
post #6 of 13 (permalink) Old 04-21-2017, 04:14 PM Thread Starter
Member
 
Join Date: Apr 2017
Posts: 5
Quote:
Originally Posted by joe4500 View Post
2001
24000
no codes no FI light at all
battery checked good cleaned bat connection. no power (12 v) at ecm connectors.
joe4500 is offline  
post #7 of 13 (permalink) Old 04-21-2017, 05:19 PM
Seasoned Member
 
Join Date: Aug 2008
Location: Chicago, Illinois
Posts: 1,760
Check your fuse with a meter. Visual can sometimes be deceiving.

2007 Comfort/Nav/ABS

Prior:
1993 ST1100
1983 CX650

I'll go totally green and give up my GoldWing when Al Gore gives up his charter jet.
ChgoD is offline  
post #8 of 13 (permalink) Old 04-21-2017, 06:47 PM Thread Starter
Member
 
Join Date: Apr 2017
Posts: 5
I used a test light
joe4500 is offline  
post #9 of 13 (permalink) Old 04-21-2017, 07:54 PM
Super Moderator
 
Ironhorse1800's Avatar
 
Join Date: Mar 2012
Location: Sugar Land, Texas
Posts: 4,147
Quote:
Originally Posted by joe4500 View Post
2001
24000
no codes no FI light at all
Ok. @techdude2000 is really the best at this and I will gladly yield when he comes along.

With kickstand down and in neautral, If you crank for 10 seconds and release, you should get a flashing code on the FI light. The fact that you got nothing seems to indicate no power to the ECM.

With key on, I only get the FI light if my kill switch is in the run position. I can cycle the FI light by turning the kill switch back and forth. So, try key on and wiggle, jiggle the kill switch to see if you can get the FI light to flicker. It would be great if that simple, but will surprise me too. Just to simple to pass up. Since it does spin over, I kind of doubt the kill switch is an issue. But ...

I have read about early, '01-'03 ECMs going bad, but don't think they tended to just die. Other issues seemed to show up first.

Another thing that can kill it is lost signal from the crank position sensor. Read some on that here: Bike won't start!

Ironhorse1800, Hoss
2004 VTX1800N3 Red, Darkside Goodyear Assurance Tripletred 205/60/R16
2008 GL1800 ABS/NAV Red, Darkside #1273
[B]Michelin Primacy Alpin PA3 195/55/16 / [COLOR=#000000]Yokohama Avid Envigor ZPS
Ironhorse1800 is online now  
post #10 of 13 (permalink) Old 04-21-2017, 10:46 PM
GL1800 Doctor
 
Join Date: Sep 2004
Location: Lexington, KY
Posts: 15,997
No voltage at the ECM can be a lot of different things. It's not the kill switch or the starter would not be spinning the engine. It being a 2001, it could have had a C5 meltdown. First thing to do is to take a meter and measure for power coming out of the FI/IGN relay with the key on. You should have power on the black wire all the time, power on the black/white wire and the black/yellow wire with the key on. You should have very little to no voltage on the red/white wire with the key on. All of these are using the battery negative post for the ground connection while measuring. Based on these measurements, we will know which way to go next.
Ironhorse1800 and Barrycuda67 like this.

Rob's Candy Red '04

Last edited by techdude2000; 04-21-2017 at 10:52 PM.
techdude2000 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GL1800Riders forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome