Back rest issue - GL1800Riders
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 04-10-2015, 12:37 PM Thread Starter
Seasoned Member
 
awingnut105's Avatar
 
Join Date: May 2005
Location: Seneca, SC
Posts: 759
Back rest issue

I have the Ultimate King seat. It was purchased from someone who was upgrading to a heated one, so it had been used for a while. I love the seat, but the first few times that I removed the back rest, it came out fine. The last time I tried to remove it, the thing had grown roots under there and I still can't get it to slip out. Any suggestions will be appreciated.


'08 with '12 MT Adventure kit and '10 with '12 MT Adventure kit. 1,000,000 miles August, 2015
DISCLAIMER: All post are my personal opinion and are in no way intended to reflect on or change the opinions of others.
awingnut105 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-10-2015, 02:41 PM
Seasoned Member
 
Pooch's Avatar
 
Join Date: Nov 2010
Location: Utah's Area 51
Posts: 4,248
Possibly some of the foam has come loose under there and making it stick when you pull up? I'd say take seat off and look, maybe something simple.

[FONT=Comic Sans MS][FONT=Blue Highway][SIZE=2]

2010 Level 3 DDS#1146 IBA#55800 SS1K x2, SS2K,BB1500,BBGold Certified
Disclaimer:This poster does not take any responsibility for any hurt or bad feelings. Reading threads poses inherent risks. This poster would like to remind readers to make sure they have a functional sense of humor before they visit any discussion board.
[/COLOR]
Pooch is offline  
post #3 of 7 (permalink) Old 04-10-2015, 10:06 PM Thread Starter
Seasoned Member
 
awingnut105's Avatar
 
Join Date: May 2005
Location: Seneca, SC
Posts: 759
Quote:
Originally Posted by Pooch View Post
Possibly some of the foam has come loose under there and making it stick when you pull up? I'd say take seat off and look, maybe something simple.
Thanks, but I tried removing the seat and checking under the seat. All I saw was the bottom of the pan. Didn't see anything visible as far as the back rest..


'08 with '12 MT Adventure kit and '10 with '12 MT Adventure kit. 1,000,000 miles August, 2015
DISCLAIMER: All post are my personal opinion and are in no way intended to reflect on or change the opinions of others.
awingnut105 is offline  
 
post #4 of 7 (permalink) Old 06-01-2015, 06:51 AM
Seasoned Member
 
JGDJR's Avatar
 
Join Date: Dec 2013
Location: Richmond Va
Posts: 1,969
Garage
Sorry just saw this...Did you get it out?? I would say just spay a little WD-40 down inside...I believe it has a ball lock that holds the backrest in place...just a though

John
JGDJR is offline  
post #5 of 7 (permalink) Old 06-16-2015, 06:12 PM Thread Starter
Seasoned Member
 
awingnut105's Avatar
 
Join Date: May 2005
Location: Seneca, SC
Posts: 759
Quote:
Originally Posted by JGDJR View Post
Sorry just saw this...Did you get it out?? I would say just spay a little WD-40 down inside...I believe it has a ball lock that holds the backrest in place...just a though John
Thanks. I finally decided that Ultimate wasn't monitoring this site very closely, so I contacted them by email. That was their suggestion and it did the trick.


'08 with '12 MT Adventure kit and '10 with '12 MT Adventure kit. 1,000,000 miles August, 2015
DISCLAIMER: All post are my personal opinion and are in no way intended to reflect on or change the opinions of others.
awingnut105 is offline  
post #6 of 7 (permalink) Old 06-16-2015, 10:58 PM
Site Sponsor
 
Ultimate Seats's Avatar
 
Join Date: Oct 2013
Location: Ormond Beach, FL
Posts: 31
Sorry We Missed You.

Quote:
Originally Posted by awingnut105 View Post
Thanks. I finally decided that Ultimate wasn't monitoring this site very closely, so I contacted them by email. That was their suggestion and it did the trick.
AWINGNUT,
Sorry we missed your issue. We try to watch and help with every bit of technical support we can. Glad everything got squared away.

Best,

Dave

Ultimate Seats
348 Destination Daytona Lane
Ormond Beach, FL 32174
USA - 877-672-0288
CANADA - 800-818-6868
www.ultimateseats.ca
Ultimate Seats is offline  
post #7 of 7 (permalink) Old 06-23-2015, 12:13 PM Thread Starter
Seasoned Member
 
awingnut105's Avatar
 
Join Date: May 2005
Location: Seneca, SC
Posts: 759
Quote:
Originally Posted by Ultimate Seats View Post
AWINGNUT,
Sorry we missed your issue. We try to watch and help with every bit of technical support we can. Glad everything got squared away.

Best,

Dave
No problem, Dave. Support was excellent.


'08 with '12 MT Adventure kit and '10 with '12 MT Adventure kit. 1,000,000 miles August, 2015
DISCLAIMER: All post are my personal opinion and are in no way intended to reflect on or change the opinions of others.
awingnut105 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GL1800Riders forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Old Thread Warning
This Thread is more than 705 days old. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
If you still feel it is necessary to make a new reply, you can still do so though.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome